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So you've finally realised. You think that new technology is
great - of course you do - but ever since you packed away that
old Spectrum in a box and taped up the lid something has most
definitely been missing.  At last you understand you were
turning your back on more than just an obsolete computer.  The
good news is that you don't have to fish the box out from under
the bed just yet (or lament its sale on ebay or at the local car
boot): the Spectrum is one of the most emulated computers (if
not the most emulated computer) on the planet and the quality
of its emulation is just superb.  Just about anything you used to
do on your old Spectrum can now be done on a PC Spectrum
emulator - including plugging in a cassette recorder to load your
favourite games.
But where do you start?  A search for "ZX Spectrum" on Google
reveals well over a hundred thousand links, many of which - to
even the most enthusiastic of  returners - can appear to make
absolutely no sense whatsoever.  TZX?  RZX? Snapshot?
Chuntey?  What's it all about?
Things have moved on since the days of "Start tape, then press
any key."  In this small book I hope to make these develop-
ments a little easier to digest.  We'll start by assuming you to be
completely new to the modern Spectrum scene and deal with
the basics of emulation, then build things up from there.  Al-
though the book is written with complete beginners in mind I
hope also that it will be useful to a variety of Spectrum
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hobbyists at various stages of their ZX rehabilitation; if, like me,
you've spent t ime lurk ing in the shadows of  the
comp.sys.sinclair newsgroup wondering whether your one little
question will be screamed at for its ignorance/naivety/ten thou-
sand references in the CSS FAQ, then I hope you'll find some
answers here.
Have fun!  That's what it's all about.

Colin Woodcock 
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The aim of this chapter is to get you using an emulator to load
and play games - just the way you used to on the real thing.  So
where do we start?  There is an absolutely enormous number of
emulators to choose from, the most complete list I know of being
at www.worldofspectrum.org/emulators.html (currently I count
well over 100 different emulators there across more than 20
different platforms).   
Over the last few years we've seen PC Spectrum emulators
make a very successful transition from DOS to Windows.  2002
to mid 2003 in particular was a fantastic period of both competi-
tion and collaboration between a number of the top emulator
authors, during which standards were driven upwards a great
deal in a very short space of time.  Since I first wrote this
introduction to Spectrum emulation in the summer of 2002 (as
the first of a series of articles for ZXF magazine) there have
been staggering improvements in many of the leading emulators.
Spectaculator, for example, had only just added in support for
the Spectrum 128 and +2 back then (versions 1 and 2 only
emulated 48K Spectrums); now it supports the Spectrum +3 and
+2A, the Russian Pentagon and Scorpion clones, emulation of
ZX Microdrives, the ZX Printer, black and white TV screens (yes,
really!) and it can now accept input from a cassette recorder
plugged in to your PC's line-in socket in one direction and squirt
out loading tones through the speaker socket to your genuine-
article Spectrum in the other.  And there's plenty more besides
that as well!
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One consequence of this rate of change is that any attempt here
to describe in too much detail the current state-of-the-art in
emulation or to attach too much importance to the differences in
existence between specific emulators today will render the book
obsolete before the ink has had time to dry.  The bells and
whistles, and the drama of emulator development are, I'm sure,
the details of the scene which you will delight in discovering all
by yourself once you've got your head around the basics!
To make things simple therefore I'll concentrate on just two
emulators for the most part of this book.  Arguably the most
comprehensive Windows Spectrum emulators about in any case,
Spectaculator by Jonathan Needle and SPIN by Paul Dunn,
Woody, Mark Boyd and Damien Guard were probably the two
programs most responsible for a lot of the progress made in the
period mentioned earlier.  Spectaculator is shareware and a 30
day trial can be downloaded from www.spectaculator.com.  SPIN
is freeware and can be obtained from the WoS emulator page
mentioned earlier on.

Virtual cassettes on your emulated Spectrum
Time to explain a bit about file formats.  The Spectrum, of
course, used cassette tape primarily as its storage medium.
That's not to say that there weren't any other ways of saving and
loading programs back then: the Spectrum +3 had a built-in 3
inch disk drive, for example, and the original 48K Spectrum had
a special Microdrive system developed for it by Sinclair
Research.  More on these later.  There were also various add-on
disk drive interfaces over the years that plugged in to the
expansion connector on the back and allowed you to use stand-
ard 5.25 and 3.5 inch disk drives such as the MGT Plus D
interface and the Technology Research Ltd BETA interface, and
we'll look at these later on too.  Despite these valiant attempts at
bringing 'mass storage' to the Spectrum, however, cassette tape
remained the firm favourite amongst Spectrum users, and this
was the format that the vast majority of software for the machine
was released on, right up to the last few commercial releases in
1993 (interestingly, a few new producers of commercial Spec-
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Spectrum models (just in case you'd forgotten)

The original ZX Spectrum, with its
quirky rubber keys, was released by
Sinclair Research Ltd in 1982.  This
model initially came in two versions -
one with 16K RAM and one with 48K
RAM. The Spectrum+, which came
out in 1984 was essentially the 48K
machine with a slightly better key-
board and a redesigned case.  The
Spectrum and Spectrum+ are there-
fore identical as far as emulation is
concerned and most emulators make
no distinction between them - they're
just referred to as 48K on the list of
models to emulate.
The 16K and 48K Spectrums both
display the famous "© 1982 Sinclair
Research Ltd" message when
switched on and both employ the
single keystroke method of entering
keywords in BASIC (for example, the
letter J would display LOAD when
pressed at the flashing K prompt).

Shortly before its sale to Amstrad Plc
in 1986, Sinclair released the
Spectrum+ 128. Visually very similar
to the Spectrum+ (Sinclair by this
stage didn't have the money to de-
velop a new case) this 128K RAM
computer was distinguishable from
its immediate predecessor by a black

metal heatsink down the right hand
side which dissipated the heat gener-
ated by all the new memory chips.  In
addition to the extra memory, a 3
channel music chip was added in
too.  A simple menu system was
introduced and the single keystroke
system was abandoned in favour of
a letter-by-letter approach.

The Spectrum +2 was Amstrad's first
128K Spectrum and also released in
1986.  A grey machine with a proper
keyboard, this was the first Spectrum
to incorporate a built-in tape deck.  It
was followed up in 1987 by the
Spectrum +3 - black, with a 3 inch
disk drive built in, and the Spectrum
+2A - a black version of the +2.
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trum software have sprung up in recent years and they too
favour cassette tape, even now).
So most of your Spectrum memories are probably about games
that you loaded from cassette: red, yellow and blue stripes,
loading tones (some Spectrum users claim they can hear the
tones even with the volume turned right down!) and - if you were
unlucky - an 'R tape loading error' message.  Any emulation of
the 'Spectrum experience' just wouldn't be even approaching
complete without including all of this palava!
Now here's the deal with cassettes: a Spectrum program stored
on tape rarely consisted of a single file. Your typical Spectrum
game, for example, would usually consist of at least three files:
the BASIC loader would come first, followed by the loading
screen usually and followed next by the main program code.  So
it's not just a question of loading individual files into your virtual
Spectrum; the whole tape that contains the files has to be
simulated if Spectrum emulators are to remain faithful to the
original experience.  This is where the file formats .TZX and
.TAP come in (the former being a more recent formulation and
more authentic than the latter).  A TZX file is, effectively, a virtual
cassette that contains all the individual files necessary for the
game to run, and your emulated Spectrum accesses this in just
the same way as your original Spectrum did, loading the BASIC
loader first and so on.  Most emulators now come with a 'virtual
cassette player,' that allows you to play, stop and forward/rewind
the virtual cassette; Spectaculator even includes a record button
and the option to insert a 'blank tape' for your own programs to
be recorded on.
This book is primarily intended for people wanting to emulate
their old Spectrum experiences on their Windows PC, but - as an
aside - if you ever do decide to actually open that taped up old
box in the attic and get out your real Spectrum to have a play on,
you'll find yet another treat in store for you, courtesy of virtual
cassette files and Spectaculator. Using the 'boost loading tones'
option in the emulator and by running a lead from your PC's
speaker out socket to your Spectrum's ear socket, you can load
games from 'virtual' cassettes on your PC into your Spectrum
just as though they were real cassettes - the Spectrum doesn't
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The virtual Spectrum cassette

The BASIC loader. The purpose of
this small BASIC program is to pre-
pare the Spectrum for the files to
follow.  When you type LOAD "" (or
select Tape Loader from a 128
menu) the Spectrum expects a
BASIC program to load; most
games, however, were written in
machine code and machine code
has to be loaded with a different set
of commands altogether (LOAD
"filename" CODE start address, file
length, for example, or LOAD
"filename" CODE followed by
PRINT USR start address).  The
BASIC loader, therefore, is a BASIC
program that loads in and executes
the remaining f i les  for  you
(effectively entering these more
complex commands on your behalf
and saving you the hassle) - first the
loading screen and next the main
program code.  The arrival of the
BASIC loader would be announced
by "Program: hobbit" (or whatever
your game was called) in the top-left
hand corner of the screen.  
The loading screen. The loading
screen was a code file loaded to the
Spectrum's screen memory at ma-
chine code address 16384.  If you
didn't black out the screen first it
would appear in a rather odd, line-
by-line fashion (it's rather hard to
describe).
The program code. The example
to the right is about as simple as
they come; as games got larger and
more complicated, the number of
program files on a cassette grew
rapidly and its actually quite rare for
cassettes to have as few as three
files in total (take multiload games,
for example).

Above: Spectaculator's cassette recorder
window lists each of the three files on the
cassette for The Hobbit: the BASIC loader
(called 'hobbit'), the loading screen (called
'p') and the main program code (called 'h')
Below: Here is the BASIC loader listing
for The Hobbit. Line 5 clears out the
memory to make way for what's coming,
lines 10 and 20 black out the screen and
prevent naughty hackers from BREAKing
into the program, line 30 loads the loading
screen into the screen memory and line
50 loads the main program code.  Line 60
runs the main code (from address 27648)
once it's loaded.
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Working with cassette images: loading (48K mode)

Spectaculator: Select a cassette file to load into your virtual cassette recorder (don't
forget to open the cassette recorder window first using View > Cassette Recorder) via
File > Open (a cassette file will end in either .TAP or .TZX).  On your emulated
Spectrum type LOAD "" (the J key for LOAD, don't forget, and the " symbol is obtained
with a right shift and P) and ENTER.  Click play on the tape recorder.  Depending on
whether you've selected flashloading or not (the little lightning symbol), the game will
either instantly appear or load in 'real time,' loading tones, stripes and all.

SPIN: To select a cassette file on SPIN use File > Insert Tape; to open the cassette
recorder window select Tools > Tape Options > Open Tape Browser. Apart from that
it's the same deal, although the " symbol on SPIN is obtained this time with Ctrl P.
Additionally, loading speed is set in Tools > Options > Images.
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Working with cassette images: saving (48K mode)

Spectaculator: Saving to tape in Spectaculator is simple.  To create a new, blank tape
and insert it in the cassette recorder, all you have to do is select File > New > Audio
cassette file and give your new tape file a name.  In it goes.  In the main emulation
window now type SAVE "gamename" (SAVE resides on the S key) and press ENTER.
Up comes the message "Start tape, then press any key." - press record on the cassette
recorder (the circle) then click on the main emulator window and press any key.  Done.

SPIN: To create your blank tape in SPIN, select Recording > Tape Recording > Insert
Tape For Saving and give your tape file a name.  SPIN is a little confusing in that this
new tape doesn't now appear in your on-screen tape recorder (it's a bit like having a
second (invisible) tape recorder, just for saving on).  But everything else is the same:
SAVE "gamename" and ENTER; hit a key at the "Start tape..." message.
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know the difference at all!  Which means that most of the several
thousand odd Spectrum titles to be found on the internet (more
on this in chapter two) can be used directly on your real Spec-
trum as well as your emulator.  How cool is that?

Snapshot files
Before virtual cassette files (or 'Cassette images,' as they're
sometimes called) were sorted out, the mainstay of the spectrum
emulator was the 'snapshot file'.  A snapshot file is essentially a
memory dump (or 'snapshot') of the Spectrum's memory at any
given point - most game snapshot files that you can download
from the Internet have been saved (or 'snapped') just at the point
at which they've loaded.  The origins of this file format go back to
the days of the original Spectrum hardware: with all these add on
disk drive devices (and eventually the +3 three inch drive) a way
had to be thought of for transferring existing software owned by
an individual from tape to disk (where was the point in owning a
posh new disk drive if you couldn't use it to speed up the loading
of all your favourite games?)  Most games protected their BASIC
loader from easy hacking, hiding the listing (and therefore the
start addresses) through special tricks that left a blank screen
and perhaps a copyright message, so it wasn't just a matter of
loading the file into memory and then saving it back onto disk
with a new BASIC loader modified as appropriate.  Disk drive
interfaces such as the MGT Plus D, therefore, sported a little
snap button which you pressed once your game had loaded from
tape; at this point the game would freeze and you were able to
save it - as it was, at that precise moment - to disk.
So a snapshot file - in contrast to a virtual cassette file - really is
just one file. You don't get the BASIC loader or the loading
screen with this sort of file; when you load it back in you just go
straight back to the point at which you saved the file, be that at
the start of a game or somewhere in the middle (at the end of a
level, for example, so you don't have to play the game right from
the beginning next time).  Snapshot files were great at the time -
a convenient way of loading a favourite game quickly - but as
emulators developed and the pangs of nostalgia for the good old
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days grew, something more authentic was required; also snap-
shots were no good for multi-load games (where each level in a
game had to be loaded separately from tape).  These days,
therefore, the preferred format for distributing Spectrum software
in is cassette format; snapshot files are mainly used for saving
your progress in a game (although a particularly innovative use
for snapshot f i les has been implemented at
www.thespian.demon.co.uk/congrat/index.htm, otherwise known
as 'The Congraturations Archive,' where you can download
snapshots of games at their point of completion to find out what
happens at the end).  
The two main snapshot formats - both of which have been
around for years - are .SNA and .Z80; both are supported by the
vast majority of emulators (and both support also 48k and 128k
snapshots).  More recently, however, Jonathan Needle has
developed a new snapshot format called .SZX for his emulator
Spectaculator. SZX files include hardware state information and
this is a reflection of sorts of just how far emulation has come
since the formulation of .SNA and .Z80.  An SZX file, therefore,
doesn't just save the state of your Spectrum at the point of
snapping, but also the state of any peripherals - most importantly
the cassette recorder and any disk drives.  So say, for example,
that you load up a multiload game from cassette into an emu-
lated Spectrum +2 and make it to the end of level two of the
game before SZX snapshotting it; the next time you load that
SZX file into Spectaculator the emulator will switch to +2 mode,
load in your game at the point at which it was snapped and insert
the relevant cassette into the cassette recorder (in the position it
was in when the save took place).

Disk/cartridge images
And so to 'mass media'.  There were two 'official' mass media
formats for the Spectrum: Sinclair's own Microdrive system for
the Spectrum, Spectrum+ and Spectrum 128 (microdrives - of
which you could attach eight - plugged into the Sinclair Interface
1); and the 3 inch disk drive built into the Spectrum +3.  Both
systems are supported by both SPIN and Spectaculator.
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Working with microdrive cartridges

The microdrive was one of three expansion possibilities to the Spectrum offered by the
ZX Interface 1, the other two being the local area network (you could connect up to 64
Spectrums) and the RS232 serial port.  Sinclair wanted to keep the basic syntax for all
three of these the same and the result was not for the faint hearted.  When entering a
LOAD/SAVE/FORMAT, etc command you not only had to identify the destination of the
data (ie, microdrive, network or RS232), but the number of the drive or station too.  So:

LOAD�"m";2;"Squares" would load the program "Squares" from 
 microdrive 2 but;

LOAD�"n";5 would load a program from network station 5 and;
SAVE�"b" would send your program to the RS232 port ('b' is 

 for binary as opposed to 't' for text).

Not only does Spectaculator offer support for microdrives (you can have up to 8, just
like the real thing) and RS232, it also emulates the microdrive's motor sound!  For both
emulators, IF 1 is enabled via Tools > Options > Hardware. View > Microdrives brings
up the microdrive panel in Spectaculator; File > Microdrives does the same in SPIN.

network
connectors

RS232

The ZX Interface 1
sat underneath the
Spectrum.
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Working with +3 disks

Amstrad's +3 disk system was much simpler to use than microdrives were.  Essen-
tially you just used the same old commands you were used to using with tape:

LOAD "squares" SAVE "squares" LINE 1 VERIFY "squares"
And so on.  You could change back to tape by typing in SAVE "t:" before any save
commands or LOAD "t:" before any loads (to switch to disk again type LOAD/SAVE "a:" 

To insert a blank disk in Spectaculator choose File > New > Blank +3 Disk; in SPIN
choose File > Insert Disk > Create New. The standard +3 disk was a 360K 3" CF2 disk
(180K per side), but you could also plug in a standard 3.5" 720K disk drive via the
computer's Drive B port; both emulators will allow you to create either disk image.

Emulator basics   11 



So, in the same way that cassette file formats such as .TAP and
.TZX work as 'virtual cassettes,' so disk file formats work as
'virtual disks' or 'disk images'.  Pop the image file into its drive via
the appropriate emulator tool and then access it from within your
emulated Spectrum in exactly the way you would have done on
the real thing.  For +3 disk images the standard file format is
.DSK and for microdrive cartridge images the standard file for-
mat is .MDR.
Of course, there were plenty of other add-on disk drive devices
for the Spectrum in its time; we'll have a closer look at some of
these later in the book.

The keyboard
By now you should pretty much know all you need in order to get
back to playing those favourite games from your more youthful
times - the next chapter will tell you where to get the games
themselves from, and you might just decide at that point you
need  read no further.  It's worth paying brief attention, however,
to the business of the Spectrum keyboard before pushing on,
even if it's just to remind yourself which key the quotation marks
are on.
Of course, from the Spectrum 128 onwards there was no need to
type anything into your Spectrum at all to load a game - just hit
enter at the main menu to go into the 'Tape Loader' and then
press play on your cassette deck.  Regardless, just as we often
seem to forget that not all Spectrums had rubber keys, still we
mostly associate playing games in those days with having to
type LOAD "" first!  And let's be honest - no matter how much of
a die-hard gamer you were or still are, it's nice to be able to dip
back into ZX BASIC every now and again.  The problem that
emulation brings to this, however, is that our PC keyboards lack
those essential keywords, and all the symbols are in the wrong
places!  How do we get around this?  Well, there are a few ways.
One of the things that distinguishes Spectaculator from other
emulators is its great help system.  Pretty much a reference
document in its own right, the help menu also includes a
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'keyboard map' in which you can look up keywords and symbols
(or 'tokens' as they are also known) to find out the keyboard

The Spectaculator
keyboard map: click a letter
and browse the tokens.

combinations required to get to them.  Your fingers will still have
to do the dancing, but at least they'll have some idea of where to
go.

The SPIN keyboard helper: at last, the emulation of rubber keys.
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SPIN's authors have taken a different approach with their fantas-
tic keyboard helper.  Regular readers of ZXF will know that I'm a
great fan of this feature, essentially a virtual 48K keyboard with
keys you can click on with your mouse - all combinations
allowed!  The keyboard helper has two other modes too - one
that allows you to select individual commands and send them
straight to the Spectrum and another that allows you to type
whole lines of BASIC straight into a text box that can then be
checked for errors and sent to the Spectrum at the click of a
button.
One final way around the 48K keyboard problem is to use a
customised ROM that allows keywords to be entered on a letter-
by-letter basis (just like the 128 did), rather than using the single
keystroke approach (PRINT on P, LOAD on J, etc).  The 48K
Spectrum had a 16K ROM (Read Only Memory) and a number
of alternatives to it have been designed within the Spectrum
community over the years.  The most useful for our purposes
here is undoubtedly a ROM by Geoff Wearmouth called 'Gosh
Wonderful.'  The Gosh Wonderful ROM allows you to type
keywords letter-by-letter whilst maintaining compatibility with
most existing Spectrum software.  It makes the business of
typing on an emulated 48K a great deal easier - so much so that
I pretty much use it as my default ROM for 16/48K emulation on
Spectaculator. You can download the Gosh Wonderful ROM
from Phil ip Kendall 's Spectrum ROMs collection at
www.srcf.ucam.org/~pak21/spectrum/roms.pl. To install it, it's a
simple matter of selecting Tools from Spectaculator's menu bar,
and then Options > Advanced; click on the (None) next to
'16K/48K Spectrum' in the Custom ROMs section; locate the GW
ROM and select it: you're away.  On SPIN, select Tools >
Options > Hardware and locate the GW ROM from the 'Using
ROM image file' box.
Oh and by the way, the quotation marks are on the P key ;)
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So where do we get these games and other files from? This part
is really simple.
The Spectrum community is blessed by the work of a chap
called Martijn van der Heide; his site - World of Spectrum
(www.worldofspectrum.org) - contains the biggest archive of
Spectrum files on the planet - over 11,000 titles at present.
There's not an emulation site that I know of - Spectrum or
otherwise - that comes even remotely close to this sort of
content - and it's all completely free.
WoS was started in November 1995 by Martijn, initially as a web
page to host his Spectrum games database program, SGD. In
January 1997 the site started hosting games downloads
(opening with some three-and-a-half thousand titles) and it's
been updated pretty much on a weekly basis ever since.  
If you can't get hold of the title you're after amongst the thou-
sands at WoS, it's probably either 'missing in action' (also known
as 'MIA,' these missing files are listed at WoS and it's always
worth checking any old tapes you have - or any you pick up at
the local car boot sale - against this, just in case you've got
something that's needed) or it's distribution has been denied by
the original copyright owner.  Martijn has been working tirelessly
over the last few years to contact a huge number of game
authors and publishers in order to establish whether or not they
mind their work being distributed for free via WoS; a small
number have told him that in fact they do mind (for example,
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Ultimate and Code Masters, both successful companies today)
and in these cases the relevant titles are immediately withdrawn
from the site.  WoS is one of the very few (if not the only)
emulation sites on the web that goes about pro-actively seeking

distribution permission in this way, and the approach has won it
a lot of friends and a great deal of respect (authors approached
hardly ever say no).
It's not just games you can download from WoS either.  Aiming
to bring you pretty much "anything and everything from the
Spectrum era," the site also hosts inlay card scans, instructions
for games, complete magazine scans  and a whole host of
modern software downloads: emulators, utilities and more.
There's also an enormous range of documentation available,
from the original Spectrum introduction booklet and other manu-
als to circuit diagrams, schematics and servicing information.
And there's a discussion forum.  And there's a chat room.
WoS will probably be the only site you'll ever need to visit for
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Spectrum files if you're just looking for old favourites to play
again.  After a while of playing around with these, however, you
might just start feeling the need to explore some of the more
recent software releases for the Spectrum.  People are still
making new games for the Spectrum? Oh yes.
For starters there's www.cronosoft.co.uk. A UK software label
operating since early 2003, Cronosoft have been producing
software for a number of 8 bit formats, but the most so far have
been for the Spectrum.  Cronosoft titles can either be bought as
.TAP files (for between 99p and £1.99) or as real, honest-to-
goodness cassettes (these cost an extra pound on top of the
.TAP price plus a small charge for postage and packing).  I
wholeheartedly recommend Fun Park, a 16K game developed
by Jonathan Cauldwell from his original 4K entry in the 2003
Minigame coding competition.
Then there's Weird Science Software. A Hungarian develop-
ment team, WSS have produced a couple of astounding titles
over the last few years, including one which uses the Spectrum's
border as part of the playing area (you remember the border -
where you weren't supposed to be able to print anything, right?).
WSS operate from www.c-system.hu/edy/weirdsciencesoftware/
where you can either download the games for free in .TZX
format or order them on cassette.
At http://tcg.speccy.cz/ you'll find an amazing adaptation of a
PlayStation game called Abe's Mission - Escape to download for
free as a .TAP file.  It's a beautifully illustrated and animated
game.
And at www.n-discovery.narod.ru/games.htm you'll find the fan-
tastic Fire and Ice puzzle game, one of the best produced pieces
of Spectrum software I've seen for a long time.  This is also a
free download, but you'll need an emulator that emulates Rus-
sian Spectrum clones for it to work (more on these later).
Finally, if you're a Manic Miner or Jet Set Willy fan, you could do
a lot worse than head over to the dedicated Yahoo! group at
http://games.groups.yahoo.com/group/manicminerandjetsetwilly/
for a whole host of sequels and remakes, all free.
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I say 'finally,' but the reality is I've only scratched the surface;
there is loads more to discover.  For the moment, however, it's
time to learn a little more about emulators.

 18 The ZX Spectrum on your PC



So far we've looked at the two parts of the Spectrum experience
you couldn't avoid, even if you only ever used the computer for
games playing: using the keyboard and loading a program in
from your storage device.  Of course, if you were a die-hard
games fan, it's likely there was a further piece of hardware you
were used to interacting with on a regular basis - a joystick.
There were lots of different joysticks made during the Spectrum's
era; you plugged them into the Spectrum via joystick interfaces,
each of which worked according to one of a small number of
interface standards.  The Kempston standard configured the
interface as part of the Z80 Input/Output map, whilst the Cursor
standard simply linked the joystick's movements to the cursor
keys 5 to 8 (the keys with the little arrows on them) with 0 as fire;
the Sinclair standard took the same approach as Cursor, using
instead the keys 6 to 9 with 0 again as fire (the Sinclair standard
supported two joysticks and keys 1 to 5 were used for joystick
two).  Selecting Cursor or Sinclair (the Sinclair standard was also
sometimes referred to as Interface 2, since it was introduced
through Sinclair's ZX Interface 2 - an interface that plugged into
the back of your Spectrum and allowed you to plug in two
joysticks and ROM cartridges that loaded instantly) control for a
game, therefore, would allow you to use the keyboard if you
wanted (ie, keys 5 to 8 for Cursor; 6 to 9 for Sinclair); selecting
Kempston would not.
Having three different standards for joystick interfaces created a
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bit of a problem, since not all games produced gave you all three
options on their control menus (and they generally didn't say on
the box which standards they did support).  If you used a Cursor
interface, for example, and bought a copy of Exolon (which
supports only Kempston and Sinclair), your joystick would be
staying in its box whilst that game was on.  The way around all
of this was to shell out for one of the more expensive interfaces
that had three joystick sockets on them - one for each standard.
The good news is you don't really have to worry about any of this
with emulators, since all three standards are supported.  All you
need is a PC joystick or control pad plugged in to your usual
game port; selecting which standard you want is simplicity itself:
for Spectaculator just select Control > Joystick and then the
standard of your choice.  For SPIN select Tools > Options >
Control and in the drop-down box for 'PC Joystick Emulates'
click on the standard you're after.  Don't forget you'll have to
select that standard from within the game itself also.  Kempston
is probably the best-supported standard generally, so selecting
this in your emulator set-up will probably mean less fiddling in
the future.
If you don't have a joystick, by the way, you can still map your
keyboard's arrow keys onto one of the standards.  For SPIN
follow the same process described above, but select the stand-
ard you're after in the drop-down box titled 'Cursor keys
emulate'; for Spectaculator go for Control > Keyboard Joystick
(Tab or right Alt acts as the fire button).  

Printers
After joystick interfaces, the next most common category of
hardware to have been plugged into the Spectrum is probably
printers.  There were a number of ways of achieving this: for 48K
Spectrums it had to be via an interface plugged into the ma-
chine's edge connector, of course; for the 128 and Amstrad's
follow-up +2 a BT-style RS232 socket built-in could connect to
standard serial printers of the day; and the +3 and +2A featured
a Centronics port that could connect to standard parallel printers.
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Both SPIN and Spectaculator offer sup-
port for the ZX Printer, displaying its out-
put in a separate ZX Printer window.
Spectaculator offers a direct print button
(ie, it sends the ZX Printer's output
straight to your actual printer), whilst
SPIN offers ZX Printer support through all
Spectrum models (although the ZX
Printer only works in 48K mode, it will
actually work with any Spectrum - even
the +3).  For Spectaculator the printer
must first be enabled from the main
Options area.

To copy protected loading screens, try using the Multiface 1 interface (Tools > Options
> Multiface to enable it in Spectaculator, then Ctrl-M to activate it).  Pressing 'c' on the
Multiface menu will send whatever image is on the screen straight to the printer.  Don't
forget, the printer interprets any INK colour as black and any PAPER colour as white,
so what you see on the screen isn't always what you get on paper.

The printer is accessed from BASIC via the commands LPRINT, LLIST and COPY (the
L stands for 'Line').  Each time you send something to the printer, the Spectrum just
sticks it straight underneath whatever was there before.  Neither SPIN nor Spectacula-
tor support the little form feed button as yet (vbSpec, an emulator written entirely in
Visual BASIC, does, however), so you'll have to send blank lines until they do.

Working with the ZX Printer
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1 Let's suppose you have some old Tasword files on cassette you want to convert to 
a standard text file for editing in your favourite Windows word processor.  The first 
thing we need to do is configure Spectaculator so that it re-directs printer output to 
a named text file.  We'll be using a 128K version of Tasword to do the printing since
the 48K version only supports the ZX Printer or other printers via a plug-in interface
(not supported by Spectaculator); Tasword 128, however, sends its output by
default to the RS232 port (which is supported).  You can get hold of Tasword 128,
of course, from www.worldofspectrum.org - look for it in the Utilities section of the
Archive.

Before you load Tasword 128, go
to the main Options box (Tools >
Options) and select Communica-
tions Ports.
In the RS232 Serial Port section
select 'File' for Send to and then
enter a filename in the text box
beside this.   I 've chosen
'RS232.txt' and, for simplicity's
sake, saved it in the root directory
on C drive.
Now load up Tasword 128 in the
usual way: insert the tape image
into the virtual cassette recorder,
select Tape Loader from the 128's
main menu and press play. When
Tasword has loaded, eject the
cassette. 

2 Now that Tasword has loaded, we need to tell Spectaculator to expect its next input
from a real, rather than virtual cassette.

From the Tools menu, select
Load from Audio Source; this op-
tion will now have a tick next to it.
Spectaculator is now expecting
audio input from your PC's Line-
in socket.  Connect this socket to
your cassette recorder's EAR
socket.  Spectaculator recom-
mends a mono to stereo lead for
this, although I've personally
found a standard Spectrum mono
cable to work fine.  You might
need to experiment.

Walk-through: Converting a Tasword file
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If you know the name of your file,
type it now, otherwise just press
enter and Tasword will load the
first file it finds on the tape.
Remember - you're loading from
tape now; an emulated Spectrum
on a PC is no better at reading
tape data than the real thing, so
you might well need to fiddle
about with the volume settings to
get a successful load.

As soon as the file's loaded
successfully, Tasword brings it up
on the screen.
Press SymbolShift-A to go back
to the main menu, P for print and
then ENTER to confirm.
On the next screen, press ENTER
several times to get to the bottom
of the list and then one final time
to proceed.  Tasword should dis-
play a brief printing message and
then return to the main editing
screen with your text loaded.

4 To check that the process has worked, open up Notepad and navigate to your text
file (C:\RS232.txt in this case).  Now you're ready to start editing.

3 In Tasword, go to the main menu by pressing SymbolShift-A (right-shift and A on
Spectaculator).  Press L to load a file and ENTER to confirm.
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Believe it or not, Sinclair had his own printing solution for the
Spectrum on the market before the Spectrum.  The ZX Printer
was actually designed for the Spectrum's predecessor, the
ZX81, but was just as happy hanging off the back of a Spectrum
(happier, since the Spectrum could power the printer without the
need for the separate power supply required by the ZX81).  
But the ZX Printer was never intended as a way of printing out
CVs, essays or your letters of complaint to the BBC; the little,
silver 'toilet rolls' weren't exactly the most attractive presentation
of text on paper and were seen as a cheap way of creating hard
copies of program listings, nothing more.  Printer resolution
matched exactly the screen resolution, restricting you to the
same 32 columns of text you got on the telly, all in the glorious
Sinclair typeface.  You could also do screendumps of whatever
was on the Spectrum's screen (although, of course, all of the
colour information would be lost).  The ZX Printer worked by
passing an electric current across the aluminium coating on the
paper, effectively burning the surface to create the black 'ink.'  It
was a rather noisy process; a much quieter option was the
Alphacom 32 printer (known in the US as the Timex Sinclair
2040), a thermal printer that gave exactly the same output as the
ZX Printer, but which used white paper that turned black (or
blue, depending on the paper) when exposed to the heat.
So serious word processing programs for the Spectrum, such as
Tasword, didn't really expect you to be printing your literary
creation off on the ZX Printer. These, in fact, were assuming a
much more standard printer to be attached via an interface or -
for later software - via the RS232 or Centronics ports: a dot
matrix printer, for example, of the sort ordinarily attached to an
office computer.  Spectrum emulators aren't able to emulate
these specific printers in the way they are able to pretend to be
a ZX Printer, of course, however they can intercept the printer
output sent by the emulated Spectrum and redirect it to a text file
which you can then load into a normal Windows word processor.
Just think - all those teenage masterpieces you created might
not be lost for good after all!  How you set up their retrieval will
depend on the model of Spectrum your are emulating plus the
way the Spectrum software you want to print from is configured;
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have a look at the walk-through for a guided example.
Other peripherals
Other than printers and joystick interfaces, there were many
other peripherals designed for the Spectrum, an increasing
number of which are supported by emulators today.  Both SPIN
and Spectaculator, for example, support the Kempston mouse
interface (yes, Kempston again; confusing, I know) - although
the number of actual Spectrum programs which support this is
fairly small, since not many people used mice with their Spec-
trums back in the 80s.  Tools > Options gets you to the main
Options panel for both emulators; that's where you configure the
mouse settings.  Once enabled, your PC mouse takes control of
the Spectrum mouse in programs designed for this.
SPIN also supports the Magnum Lightgun via your PC's mouse.
This was a peripheral produced by Amstrad that plugged into a
BT-style socket on the back of the +2A and +3; a very small
number of games supported it.  Enabling the lightgun in SPIN
allows your mouse to take control of the crosshairs on these
games - it's not quite the same as the feel of the gun in your
hands, but it's certainly a great deal more accurate!
Did you ever fancy playing around with the little speech synthe-
sizer box that plugged into the back of the Spectrum?  Now you
can: both SPIN and Spectaculator support the Currah µSpeech
(and you can download the manual from WoS), a device which
allowed you to run together allophones (speech sounds) and
give your Spectrum a voice.  Something in the region of 50
games actually supported the µSpeech, including such classics
as Jetman, but we all know that no game could possibly come
close to the joy of achieving the best pronunciation of a swear
word in Spectrum BASIC.  Well what else was there to do with
your evenings back then?
And so on.  There are still more for you to explore - the Multiface
interfaces, for example, and the SpecDrum.  The Plus D inter-
face is examined in the next walkthrough box.  There is one
more interface which we will examine more closely - the Beta
Disk Interface - but we'll come to that later.
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Working with the MGT Plus D disk interface

Released in 1988 by Miles Gordon Technology (MGT), the Plus D was a disk
interface that allowed you to connect to your Spectrum pretty much any of the standard
disk drives of the day.  The interface was the successor by about two years to MGT's
Disciple interface (a rival to the Sinclair Interface 1) and included also a 'magic'
snapshot button and a parallel printer interface.
The Plus D uses a very straightfoward syntax; the main thing to remember is that
LOAD and SAVE commands are suffixed by either d1 or d2 depending on which drive
you are accessing (the Plus D can support two).  Thus:

LOAD d1 "squares" SAVE d2 "squares" LINE 10 VERIFY d2 "squares"
'CAT 1' lists disk contents as in the screenshot above.  And snapshot files were
denoted by an 'S' suffix for a 48K snapshot and a 'K' for a 128K snapshot, ie:

LOAD D1 "squares" S  LOAD D1 "squares128" K
To enable the Plus D interface in Spectaculator select Tools > Options > Hardware and
check the MGT/Datel Plus D Disk Interface box.  To insert a blank disk choose File >
New > Plus D disk image.  You'll need to create a system disk first using the Plus D
System Tape (available from the WoS website).

The Plus D interface is also supported by
Ramsoft's RealSpectrum emulator.  Here
the Plus D is enabled in the hardware
options box availbale via F3 (press TAB
to move from the Spectrum models to the
disk interfaces supported and select us-
ing the left and right arrow keys).  Both
RealSpectrum and Spectaculator support
the two file formats developed for Plus D
and Disciple disks - .IMG and .MGT.
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So far we've looked at emulation from the point of view of how all
the stuff you used to do is implemented in 'virtual' terms.  But
many emulators also have additional features - they offer you
tools which are in addition to the hardware and software features
being emulated (so you can do things now which you couldn't do
then).
Let's start with Pokes.  Although, strictly speaking, of course,
POKEing an address, for example to give you infinite lives in a
game, was something you could do on your old hardware, but
often not without going to an awful lot of trouble.  It's much
simpler on Spectrum emulators, which offer the direct entry of a
POKE into the game currently running via an option from one of
the main menus.  Ctrl+P brings up the POKE box on
Spectaculator, whilst SPIN's  'POKEs and Tips' box (Tools >
Pokes and Tips) allows you build up a little database for POKEs
and tips as well as being able to input them directly; you can also
apply BASIC hacks from here.
Where do you get all this information from in the first place?
Visit  The Tipshop (www.the-tipshop.co.uk), the largest on-line
collection of hints, POKEs and tips for Spectrum games
(maintained by Gerard Sweeney and Nick Humphries).  You can
also search this website direct from the SPIN 'POKEs and Tips'
box.
Input recording
Of course written hints and tips on how to get through games are
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a poor substitute for actually seeing it done.  Previously this
involved finding a suitably skilled friend and peering over his/her
(ok - let's be honest - probably his) shoulder. 
The modern equivalent of this is input recording, the function of
which is to record all the things you do whilst using your
emulated Spectrum for future playback (key presses and joystick
waggles, that is; they don't record brewing a cup of tea whilst
waiting for a game to load or cheering on the little matchstick
men in Football Manager).  When you do play back the
recording, the emulated Spectrum will appear to work all by itself
- as though instructed by an invisible user - replicating your
every move in the game you recorded.  In this way a personal
best performance can be kept for posterity and shared around
for others to learn from. 
Apart from self-admiration and helping out a friend in need, input
recording is used on an annual basis for the Speccy Games
Tournament, in which ZX enthusiasts compete against each
other for the highest score on a selected range of titles.  Usually
an 'official' snapshot file of each of the games is prepared by the
competition administrator and distributed to all participants, who
then play the games and submit the input recordings they made
whilst doing so; it's a fair, reasonably non-corruptable, way of
ensuring everybody is competing on a level playing field and that
nobody can pass off grossly exaggerated figures as their own
high score.  It also allows players to learn from others'
successes.
The two main input recording file formats are .AIR and .RZX,
with the latter introduced as the successor to the former.  The
problem with AIR files was that they could only be played back
on the specific emulator that created them: this meant in the past
that all competitors in games tournaments had to use the same
emulator (usually RealSpectrum); even if your own preferred
emulator supported AIR file recording, one created by another
emulator would not work. RZX, on the other hand, works across
emulators, so all emulators which support this format should be
able to run any RZX file created by any emulator - even an
emulator running on a different platform. 
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Working with RZX files

Recording an RZX file is very simple.  Here we'll record on SPIN and play back on
Spectaculator. Start by loading up a game of your choice (I've chosen Nebulus).  

SPIN is now recording your every move.  It's play time!  When you don't want to record
any more select Recording > Stop Recording.

Now select Recording > Input (RZX) >
Record RZX File. Give the file you're
about to create a name.

To play back the file in Spectaculator, first load the original game file in the usual way.
Now select Control > Action Replay (RZX) > Play... and select the file you recorded
earlier.  Sit back and enjoy the replay of your greatest triumph... or disaster!
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Both Spectaculator and SPIN support RZX recording.  AIR is
now considered an obsolete format and is only supported by
older emulators.

Audio/Video
Input recording is fine if you want to show off to friends with a
Spectrum emulator installed on their computer, but it is just
possible, of course, that you might want something more port-
able that can play on a computer without such software installed.
.AVI and .WAV files are - as you are no doubt already aware -
standard Windows formats for video and audio respectively, and
both are supported by Spectaculator. They're certainly not the
most efficient of file formats for these purposes, but an advan-
tage of recording in these formats is that the files created will
play on much older PCs than the current 'standard.'  And you
could always use additional tools to convert them into - say -
MPG/MP3 files; conceivably you could even encode and burn
video onto a DVD if you so desired and watch it on your TV
(there's full circle for you) - so then the recipient of your record-
ing wouldn't even have to own a computer, let alone a Spectrum
emulator.
Audio and video recording are both located on Spectaculator's
'Control' menu.
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Graphics
If all that sounds a bit too exotic for your needs and you just want
to capture a screen or two to put on a web page or email to a
friend, there are, of course, options on most emulators to create
standard Windows graphics files.  Quite a number allow you to
save screenshots as .BMP (Windows bitmap) files for editing in
a standard graphics package and just recently BMP export has
also been created for the ZX Printer, so you can now print from
your emulated Spectrum to an emulated ZX Printer and save the
printer's output as a BMP file. 
And what about doing it the other way around - wouldn't it be
cool to turn a Windows BMP into a Spectrum screen?  Z80, the
shareware Spectrum emulator by Gerton Lunter, has offered a
BMP import feature for several years now, although the control
this option offers you is quite limited.  A much better way is to
use an external program to turn your graphic into a Spectrum
screen.  The common file format developed for Spectrum
screens is the .SCR format - drop an SCR into either Spectacu-
lator or SPIN and the Spectrum screen created appears straight
away (you could then save it out as a SCREEN$ to a cassette
file).  SCRs cannot be edited by standard Windows graphics
packages, but there are a whole host of freeware programs that
can.  And that brings us nicely to the next part of this book: the
many PC utilities in existence to support and enhance your
Spectrum experience.  That's what we'll explore in the next
chapter.
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So far our focus has been mostly on emulation.  This will be the
starting point for many of you returning to the Spectrum scene,
and for many nothing further will be required.  Fair enough.
Many - not all - of the increasing number of PC utilities available
for the Spectrum are targeted at the more serious Spectrum
hobbyist - in particular those wanting more powerful tools with
which to develop new Spectrum software than the Spectrum
itself is able to provide; that's not the sort of thing likely to appeal
to everyone.   But this is not to say that this corner of the
community is all about ultra-serious coding; far from it.  Plenty of
users like to use these programs just to help them create, for
example, an entry for the annual Crap Games Competition
organised by the members of the comp.sys.sinclair newsgroup
(a competition inspired originally by the now infamous Cascade
Cassette 50 compilation of 50 quite appalling games).
Programming, after all, was part of what the Spectrum was
meant to be about, and an important aspect of its appeal today
is the ease with which it's possible to create new programs
compared to the complexity of creating programs on the PC.  In
this chapter, therefore, we'll take a brief look at the sorts of utility
available to you should you start becoming interested in this sort
of thing; I will be mentioning utilities by name, but I won't be
getting too specific about the precise details of any particular
utility - the nature of the scene is that these often tend to be
developed very rapidly and then left for quite long periods before
another burst of rapid development.  Getting too specific here,
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therefore, will render the chapter out-of-date very quickly.  Also,
don't assume that the titles mentioned here are the only pro-
grams available - there are many that won't be mentioned simply
because there are too many to go into, and it's also very likely
that programs not conceived of at the time of writing will be
taking the scene by storm by the time you read this.  I won't be
giving out URLs either.   Other than, of  course,
www.worldofspectrum.org/utilities.html.  Every utility mentioned
here will be available from that page.
Since we concluded the last chapter looking at graphics, this
seems like a good place to start in our exploration of PC utilities.
In the last chapter we looked very briefly at the SCR file format
as a means of storing Spectrum screens on your PC and there
are plenty of utilities to help you work with these without having
to go anywhere near an emulator. Of course Windows doesn't
recognise SCR files as a valid graphics format (it wasn't written
with Spectrum emulation in mind), so don't expect Windows
Explorer to displays these as pretty little thumbnails.  The very
first thing you'll need therefore if you have more than a couple of
SCRs in a folder is a viewer program. These won't allow you to
manipulate your graphics much, but they will let you look at
them.  A good example of such a program is ZX Screens by
Pavel Plíva, a very simple screen viewer which will display a
whole directory of SCR files one screen after another using the
Slide Show option.  Pavel, by the way, has a particular interest in
grabbing Spectrum screens for the purpose of creating game
maps and has produced other PC software dedicated to this
purpose (ZX Maps Creator) as well as a website at which
completed maps can be displayed  (www.zx-maps.wz.cz).
In so far as actual manipulation is concerned, there are many
titles to choose from. One of my personal favourites is SevenuP
- put simply, a Windows Paint type application that produces
SCRs rather than bitmaps.  This program by Jamie Tejedor
Gomez is a touch on the slow side - even on fast machines - but
what it lacks in speed it more than makes up for in features and
usability, such as straightforward buttons for changing INK and
PAPER colours (and turning on/off FLASH and BRIGHT) and a
very useful zoom facility (which adds in a pixel and character
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grid on high zoom levels - invaluable for pixel-perfect placement
and avoiding colour clash). 
Tony Thompson's Tommy Gun suite of Spectrum graphics utili-
ties also includes an extremely competent screen editor, as does
BMP2SCR by LCD. The latter utility's distinctiveness lies in its
ability also to convert bitmap images into SCR files, allowing you
effectively to take any image from your hard drive and turn it into
a Spectrum screen. There are in fact a number of programs that
do this (including the aforementioned ZX Screens), but
BMP2SCR employs by far the largest number of conversion
techniques to explore, each giving different results.  One such
approach, for example, is the black and white dithering of a
colour bitmap.  This has been explored also in Derek Jolly's
YASPIC (Yet another Spectrum Image Convertor), which allows
you to dither an image and then colour it in.  Both BMP2SCR
and YASPIC allow you to save your output as either an SCR
graphics file or TAP cassette file.

Programming
Quite simply, Spectrum programming has never been easier
than it is now, and this is due in no small part to the emergence
of new utilities designed to help this process.  Machine code
programmers, for example, are now able to develop their code in
their favourite text editor, assemble this directly to a TAP file and
test it there and then on an emulator, thanks to a new generation
of cross assemblers, such as Pasmo by Julián Albo.  And many
emulators (SPIN and Spectaculator included) have in-built de-
buggers for tracking down errors in the code being tested too.
The most recent version of SPIN, in fact, even features its very
own in-built assembler, so you need never leave the emulator if
you don'e want to.
For these particular tools to make any sense you'll still need to
know assembly language, of course, and that's an elite club
probably most of us don't belong to (myself included).  But you
can still achieve a great deal in the Spectrum's own BASIC - and
don't forget that BASIC can be compiled into machine code by
dedicated software such as the Hi-Soft BASIC compiler.  If your
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problem now becomes how to write better BASIC, therefore,
then you have a treat in store: Paul Dunn's BASIC development
tool BASin has been bringing Spectrum users back to program-
ming in their droves (compare the 70-odd entries to the 2003
Crap Games Competition to the 21 of the 2002 contest), be-
cause it makes the whole process of developing a BASIC
program just so much easier than it used to be.  Paul Dunn is
actually one of the key authors behind the SPIN emulator; in fact
BASin started out life with the name 'SPIN Light' and visually
resembled an emulator very closely.  Now, however, this tool
has evolved beyond all recognition from its early versions, incor-
porating a whole host of additional features, such as a UDG
(User Defined Graphics - do you remember those?) editor that
allows you to create your UDGs by clicking on an 8x8 grid which
then sends the code as line-by-line decimal entries to your
BASIC listing.  BASin is one of the most innovative new PC
applications to hit the Spectrum scene in a long time and its
development looks set to be very exciting indeed.  

Music
The Spectrum beeper was so famously bad that many seem to
recall it as a feature of all Spectrums, rather than just the original
Spectrum and the Spectrum plus. Of course with the Spectrum
128 came our very own three Channel AY chip and with it a
whole new level of musical possibilities was added to the Spec-
trum scene. To listen to an AY tune you would ordinarily, of
course, have to load up the game it was part of onto your
emulator or real Spectrum. Now, however, you can listen to it
independently using an independent AY player. AY-3-8910/12
Emulator by Sergey Bulba is particularly powerful because it not
only allows you to play ready made AY files (you can download
these, incidentally, from WoS), but also to rip them  from snap-
shot or tape files yourself.  It's not just Spectrum games that
contain AY music, by the way; there is an ever-increasing
number of demo soundtracks that you can also get hold of
through WoS - and some of these are simply amazing.
One thing that does appear to be missing from the utility scene
at the moment is an AY sequencing tool.  A sequencer in the
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The main programming window
(left) can be used to enter code
directly or you can cut and paste
from a text editor.  Don't be
fooled by the 'Spectrum look,' by
the way - this is not an emulator,
it's a fully fledged editor that al-
lows you to enter keywords letter-
by-letter instead of having to re-
member all the awkward key-
board combinations (and, yes,
the quotations mark is where it's
printed on your keyboard, not
somewhere on the P key).  At the
same time, however, it does
check your code.  A variety of
debug windows accessible from
the View menu will allow you to
watch the antics of your variables
as the program runs and you can
renumber at any point in incre-
ments of your choice.
Below, the inspired UDG editor
allows you to grab the UDGs from
your BASIC listing, alter them and
stuff them right back in.  Or use it
to create fresh UDGs from
scratch - the editor creates all of
the DATA statements for you at
the click of a button.

Working with BASin
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Above, the Display Output window shows you the program running - just like on the
real thing.  When your program is finished you can build a TAP or TZX file containing
it then load it into an emulator or actual Spectrum.  You can also export your program
as a snapshot file if you prefer.
Below, the Token Table allows you to send a whole range of difficult keypresses
straight to the code window - just double click that UDG and in it goes.
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piano roll style (used by PC midi sequencers such as Cakewalk)
that generated AY output which could be saved either as an AY
file or a TAP file would be really, really useful.  Hint hint.  As it is,
there are plenty of tools with which to create AY music, but these
are actual Spectrum programs, and most follow the tracker
method of interface, which is a little complex, to say the least.

Using these tools, however, some fantastic tunes have been
created over the last few years, and not just for games and
demos either.  Multi-national group AY Riders have so far
released three whole albums of music using the Spectrum's AY
chip (you can download the albums from their site -
http://ayriders.zxdemo.org - for free and in MP3 format) - they've
even gigged live in Poland in front of 200 odd people using real
Spectrums (and lots of them).

Organising your games/research
As I said earlier, not all PC Spectrum utilities are about develop-
ing new Spectrum software.  Some simply aim to help you
organise the software you already have on your hard disk.  Via
the World of Spectrum website, after all, you now have access to
literally thousands of Spectrum titles for your emulator (or real
Spectrum) - more than you could ever have imagined yourself
having back in the 80s - and sifting through even a small
percentage of these on your PC can be an overwhelming
process.  You could sort all the games into folders by publisher -
or author - but this would be a rather long and arduous process.
Spectaculator offers a 'favourites' menu, which you can organise
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just like your Internet Explorer favourites (so the files themselves
can stay in a single folder), but this too has to be set up in the
first place.  Also, neither of these options gives you any addi-
tional information about the games (ie, author, publisher, year of
release and so on).
There are now a number of games database programs you can
use to help you sort all this out.  Perhaps the most well-known of
these within the Spectrum community is WoS maintainer Martijn
van der Heide's 'Spectrum Games Database' (SGD).  A DOS
program now no longer maintained, SGD not only gives you
information on your games (the database program itself is empty
when you download it, but you can download pre-prepared
database files from WoS along with the program), but also link to
the actual files on your system, display their loading screens and
allow you to launch them in an emulator of your choice.  More
recently, Paul Thompson has taken the universal emulator front-
end Gamebase and customised it with a ready-made database
of Spectrum titles (the database is far from complete, but up-
dates are frequently released; Paul has started with the most
popular titles and is working through the archive steadily).
Gamebase ZX, then, performs the same sorts of task as SGD,
but can also link to Inlay card scans and instructions text files.
It's also a Windows program.
It's worth bearing in mind that - as a research tool - the WoS
website itself is just as comprehensive as either of these utilities.
Often the sheer size of the WoS archive eclipses the immense
power of the internal database and search engine, custom-built
for the site.     Clicking on a game title will often throw up links to
the game's inlay card, instructions, advertisements for the game,
reviews of the game in any of the Spectrum magazines and
hints/tips/pokes/maps for the game (linking into the Tipshop's
database) as well as the actual game file itself.  All titles within
the archive can also be played on-line using the excellent ZZ
Spectrum Java emulator (which runs in a web page, so you don't
even have to have an emulator installed on your computer).
Clicking on the title's author will usually throw up a list of other
titles by the same author (each of which can be clicked and
explored in the same way); clicking on the title's publisher will
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usually throw up a list of other titles by the same publisher... and
so on.  A ratings system has been introduced for all titles and
you are encouraged to contribute your own ratings so that an
increasingly representative indication of how popular the title is
can be developed.    The complexity of the system (never mind
the content) is mind-boggling, and it's unlikely that any off-line
database will ever come close to matching it.
It's not just WoS that offers a lot of structured information either.
Plenty more websites generate a great deal of information about
various different aspects of the machine and its influence.  As
the amount of on-line, Spectrum related information continues to
grow, it's becoming increasingly difficult to find any one particular
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piece of information amongst it all.  And that's why Gerard
Sweeny invented the Speccy Search Bar for Internet Explorer
and other web browsers.  Install it and you get a little search box
in your browser's tool bar that searches nearly all of the sites
listed in Appendix I.  A real time saver.

Tape utilities
One final category of utility worth looking at is utilities for working
with and creating cassette files.  As discussed earlier, a .TAP or
.TZX file is actually an emulated cassette, if you will, containing
any number of actual Spectrum files.  Emulators like SPIN and
Spectaculator that have a separate cassette recorder window list
those files on the tape in the order that they come.  Beyond
looking at these files, however, there's not much more that you
can do with them - other than load them, of course - and whilst
that's fine in the vast majority of cases, there are occasions
when being able to delete individual files from the tape or
change the order that they play in could come in handy.  
The undisputed king of cassette file manipulation was originally
WoS maintainer Martijn van der Heide's 'Taper'.  In addition to
letting you play around with the individual files on a tape, Taper
also lets you copy files between tapes, play tapes out to a real
Spectrum and turn input from a cassette recorder plugged into
your PC into a TZX file.  Taper is still a powerful program to use,
however - like Martijn's Spectrum Games Database - it's a DOS
only program that can experience problems on modern PCs.  It's
a very great shame, but so far, there is no single Windows
program that is able to do all the things that Taper can; happily,
however, you can achieve most of the it's functions through a
combination of other utilities.
Tape Explorer, for example, is a great little Windows program by
Dan Fry that allows you to move and delete files on a Spectrum
cassette in pretty much exactly the way I described earlier.  This
utility only works with TAP files, however.  Spectrum Tape
Loader by Jocelyn Gibart offers similar functionality with both
TAP and TZX files, although this allows you to move blocks
rather than whole files (a block is a part of a file; most files are
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Walk-through: Converting a real cassette into a cassette image
Converting real cassettes into TZX files has been likened to a black art that some
achieve with ridiculous ease whilst others fail miserably at.  This is an approach to
conversion that moved me from the latter to the former group.  It might work for you too.
1 Connect your cassette recorder to your PC's Line-In socket.  Fire up your favourite

PC sound editor and set up a new file: make the file 8 bit mono (not 16 bit).  Press
play on your cassette player and record on your sound editor.  Save the resulting
WAV file somewhere handy.

2 Load up Ramsoft's 'MakeTZX' and locate your WAV file.  MakeTZX claims to be
able to convert straight from your tape recorder using 'Direct Mode' (ie, no need to
sample in a separate sound editor) but in practice this doesn't always work
(probably a hardware issue).  Enable the digital filter and press Start.

3 Seconds later - if you're lucky - one TZX file to load into an emulator or submit to
WoS for others to enjoy if it was Missing In Action.
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made out of two blocks - the header [the bit that announces the
name of the file] and the main code), making the process slightly
more complex for the beginner.  Spectrum Tape Loader also
takes input from a real cassette being played in through your
PC's sound card, which it can then turn into a TZX or TAP file.  I
must admit that I personally have not had much success in using
this particular utility for this purpose, however, whilst I have
managed it with MakeTZX by Ramsoft (see the walk-through).
You can, of course, make a new TZX file straight out of an
emulator if you're creating programs of your own; TZX creation
programs are aimed, of course, at the capture and preservation
of existing games on cassette.  Information stored on magnetic
tape doesn't last forever, after all, so simply collecting the cas-
settes themselves isn't enough insofar as preservation is
concerned.  As the archive of games at WoS grows there are
naturally less and less cassettes that haven't already been
captured in this way, thanks to the extremely hard work of the
few individuals who contribute to this project.  But there are still
some.  And by 'some' I mean hundreds.  These are the 'missing
in action' titles that have yet to be found and converted.  They
turn up in charity shops and car boot sales, and it's our job to
find them!  You can check out the current list of MIA titles at
www.worldofspectrum.org/mia.html and, if you find one of them
and manage to TZX it, you can upload your work at
www.worldofspectrum.org/upload.html.
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So far we've looked at emulation of the various ZX Spectrum
computers made by Sinclair and Amstrad. In fact that's only a
part of the Spectrum story overall.  One of the reasons for the
machine's longevity is actually that it's been cloned all over the
world, most significantly in Eastern European countries.  You
thought the IBM PC was the only cloned computer?  Think
again.
Of greatest significance of all are the Russian Spectrum clones
and their support for an English disk operating system called TR-
DOS. Take a brief look at the WoS archive and you'll find that
there are almost as many TR-DOS disk images listed as there
are +3 disk images.  Unlike the +3 disks, however, these are not
games you can also get hold of on tape or in tape files (many of
the +3 releases were actually available also on cassette, so the
main advantage of obtaining a version on disk was often just
faster loading times).  The TR-DOS format is also very popular
within the demo scene, with over 350 titles listed at Demotopia
(www.zxdemo.org) at present.  And you'll also find many, many
TR-DOS downloads at such sites as Power of Sound
(www.pos.fmshop.ru), and Scenergy (scenergy.natm.ru).  Basi-
cally a whole new dimension to Spectrum computing, then.  And
quite a refreshing one too, because the ideas and presentation
in these programs are often quite different from that of the
western software with which we are familiar.  The technical skill
with which TR-DOS programs are put together is also often
breathtaking.
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In case you're unaware, the Russian clones evolved as a result
of two main factors - price (an original Spectrum would have cost
several years' salary in Russia) and the technology export con-
trols of the Cold War.  For all the restrictions, however, a few
Spectrums did get across the Iron Curtain; once there they got
reverse engineered so that functionally equivalent (but cheaper)
machines could be built.  The results were rarely visually attrac-
tive (many of the clones were produced as designs rather than
actual computers you could buy off the shelf, so it was up to you
what your completed Pentagon looked like, for example), but -
and this is the ironic bit - they were often more powerful than the
actual original Spectrum, particularly in terms of memory and
storage features.  One such feature was the BETA Disk Interface
developed by Technology Research Ltd. An English company
(based in Middlesex), Technology Research originally released
the interface for the sum of £109 in 1985 (this was just for the
interface - disk drives you had to buy separately).  It wasn't a
particular success in the UK (ever see one on ebay? thought
not); but in Russia the interface (or rather - I presume - a clone
of the interface) actually got built in to quite a number of the
Spectrum clones, making the floppy disk a much more common
form of program storage for the Spectrum than it ever became
over here.  And hence the large amount of software available for
it.
Support for Russian machines and TR-DOS, therefore, is a key
feature of many emulators.  The two most emulated clones are
the Pentagon and the Scorpion. Spectaculator added in this
support at version 6 whilst other emulators have featured  sup-
port for a long time.  The two main TR-DOS file formats that
emulators use for TR-DOS disk images are .TRD and .SCL.
TRD files are dumps of a whole disk image, empty spaces and
all, whilst SCL files are only as big as the actual TR-DOS files
they contain (although they still work just the same as TRD
images).  The capacity of an empty .TRD file is 640K (equating
to a double sided, double density 3.5 inch floppy, although in fact
the original Beta Disk interface was also designed to be used
with a range of other drives, including 3 inch and 5.25 inch), so
a .TRD file containing a 10K Spectrum program would still be
640K in size, whilst its .SCL equivalent would be just 10K.
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Both the Pentagon 128 and the Scorpion 256 employ variants on
the 128K Spectrum's menu system.  For the Pentagon the layout
of the main menu is identical to that of the original 128 except
that  in the place of the original 'Tape Tester' we now have a TR-
DOS option.  On the Scorpion there are two TR-DOS options -
one for 48k and one for 128K.  Generally speaking, you can
make the expectation of most TR-DOS software that it will load
in the Pentagon's TR-DOS mode (ie, this seems to be the
default).  Scroll down, hit ENTER and you are now at the main
TR-DOS command line.  
Then DOS commands themselves are very simple, although
you'll need to know the keyboard whereabouts of  Spectrum
keywords as it uses the single keypress system of the 48K
Spectrum.  The CAT command, for example, reports on the
contents of a disk, (CAT is SYMBOL SHIFT + 9 in extended
mode).  Selecting a particular file for loading is then a simple
matter of LOAD "filename" - exactly as though you are dealing
with a tape (compare this with Sinclair's own microdrive syntax:
LOAD *"m";1;"filename").  This is pretty much how it goes for all
the other commands you are used to for dealing with tape -
SAVE, MERGE and VERIFY all work in the usual way - a main
addition is the RUN command, which you can use with a
filename to LOAD and then RUN that program all in one.
Although the focus of this book so far has been on the features
offered by Spectaculator and SPIN, it is worth mentioning one
other key emulator at this point.  RealSpectrum, which we'll look
at in a little more detail in the next chapter, is a DOS emulator
which has offered TR-DOS support for quite some time.  Where
the support that this emulator offers is (currently) unique is that it
will actually read from and write to genuine TR-DOS formatted
floppy disks through your regular PC floppy drive.  This Real
Disk Access is not supported in the Windows build of RealSpec-
trum (the version specially compiled for Windows XP users, also
known as RS32), but if you have an older PC capable of running
DOS programs (the DOS build of RealSpectrum will run quite
happily on Windows 95/98 systems) this is a real plus if you
happen to have any old TR-DOS disks lying around that you
want to convert into images.  RealSpectrum is by Ramsoft and
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Selecting Pentagon mode on Spectaculator is a sim-
ple matter of clicking on the mode selector icon (the
little Spectrum picture) and choosing Pentagon 128. At
the main Spectrum menu select TR-DOS.
To view the disk drive panel (above right) select View >
Disk Drives. TR-DOS supports up to four disk drives,
which you can configure from the Beta 128 Disk Inter-
face tab on the main Options panel (Tools > Options).
To select a particular disk image, click on the word
'Empty' next to a drive letter and find the image you're
after on your hard drive.
At the TR-DOS command prompt, CAT (symbol-shift 9
in extended mode - extended mode in Spectaculator is
reached by pressing left and right shift on your key-
board together; symbol-shift is a right shift by itself) will
list your disk's contents.  TR-DOS works with drive A as
its default; to change drive type *"b:" for drive B, *"c:"
for C and *"d:" for D.  Your commands after this are the
usual LOAD "filename", SAVE "filename", etc that
you're used to; an exception is the RUN command,
which you can use to LOAD and RUN a BASIC pro-
gram (ie, RUN "game").  To get out of the command
prompt and back to the normal Spectrum menu type
RETURN (just the Y key) and ENTER.
As with all other media on Spectaculator, creating a
new TR-DOS disk image is simply a matter of selecting
File > New; select either Blank TR-DOS disk (.scl) or
Blank TR-DOS disk (.trd).

Working with TR-DOS
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can be downloaded from www.ramsoft.bbk.org.

 48 The ZX Spectrum on your PC



There have been so many Spectrum emulators developed for
the PC and other platforms that it would be remiss of me to
neglect to mention at least a few others.  We've focused so far
on Spectaculator and SPIN because these are arguably the
most comprehensive Windows emulators about at present and
they also present a very intuitive user interface; but that's not to
say that other emulators have nothing further to offer.  Far from
it.  In this final chapter, therefore, we'll take a brief look at some
of the other PC emulators and their distinguishing features.  I
can't cover every single emulator about and so I apologise in
advance for those in the know who feel I've omitted to mention a
particular program they feel to be important.  Suffice to say,
they're all excellent and every single one of them contributes to
the extremely high quality of the resources with which the
community is blessed.
All of the emulators mentioned here can be obtained via the
WoS website's emulators page.  Best of all, they're all free.

RealSpectrum
For a long time, Ramsoft's RealSpectrum was the Spectrum
emulator that stood head and shoulders above the rest.  It is still
an extremely comprehensive emulator and it continues to offer a
significant number of features that other emulators don't.  Real-
Spectrum is a DOS emulator, however, and, one-by-one, many
of its features are starting to appear in other emulators.

Chapter Seven
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RealSpectrum comes in two versions - the main DOS build
(RSDOS) for MSDOS and Windows up to 98, and a version that
will run on Windows XP (RS32).  One of the key features of this
emulator is its support for a very wide range of disk interfaces,
including the Beta 128 disk interface discussed in the last
chapter, MGT's Disciple and Plus D interfaces and the Opus
Discovery interface and drive.  More impressive still is its RealD-
isk support for many of these formats which allows you to access
or create actual floppy disks for the system via your PC drive
(although this doesn't work for RS32).  RealSpectrum also sup-
ports some of the more recent developments in the DIY hard-
ware scene such as Garry Lancaster's +3e hard disk Interface
and ROMs and Sami Vehmaa's ZXCF compact flash interface.
Ramsoft are currently focusing their efforts on a new, state-of-
the-art program which they have promised will change Spectrum
emulation completely.  Currently named RealX, the new project
is eagerly anticipated by the Spectrum community and might well
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establish the Ramsoft team as the kings of Spectrum emulation
once again.
EmuZWin
A relative newcomer to the emulation scene, Vladimir Kladov's
EmuZWin has made its mark through its support for 256 colour
games, a format first developed by Iñigo Ayo and David Goti for
their own emulator Spec256. Spec256 hasn't been developed

for five years now, due in part to the lack of interest in develop-
ing new 256 colour overlays (the idea is to take an existing game
snapshot and then map onto it a 256 colour 'overlay' which is
then substituted in for the game's original colours).  EmuZWin
has done a lot to change that, with its in-built 256 colour overlay
editor; now creating new overlays is much more straightforward
(in fact, a dedicated web page for 256 colour Spectrum games
has been published at www.arjun.150m.com/ZX256games.html).

256 colour games is only one of EmuZWin's features, of course;

The EmuZWin GFX editor: a segment of a 256 colour rework of Cybernoid is shown.
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it also features an in-built map editor and a rather nifty menu link
to an external program called Lens Key written by Simon Owen.

Lens Key is a tiny utility that decodes the optical scrambling of
Lenslok protected games such as Tomahawk and Elite. The
Lenslok itself was a little plastic window that was supposed to
bend the jumble on screen into a legible code you then typed
into the computer.  Lens Key performs exactly the same function
but, in contrast to Lenslok, it actually works.  The utility will
actually work with any emulator, but EmuZWin is the first to
actually call it from with the emulator itself (you can pick up Lens
Key at http://homepage.ntlworld.com/simon.owen/lenskey/).

vbSpec
A lovely little emulator, vbSpec is the only dedicated Spectrum
emulator that I know of to include support for  the Timex TC2048
alongside conventional Spectrum modes.
The what?  A quick history lesson: the Timex Sinclair partnership
was Sinclair's way of getting into the American market and
resulted in the TS range of computers - the TS1000 and TS1500
being American versions of the ZX81 and the TS2068 being the
American version of the ZX Spectrum.  In fact the TS2068 was
quite an improvement on the British Spectrum, sporting built-in
joystick ports, a cartridge port, three channel sound via an AY
sound chip and - most impressive of all - extra video modes: one
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doubled the Spectrum's horizontal screen resolution, making it
much more suitable for word processing; another reduced at-
tribute clash massively by enabling two colours per character
line of eight pixels rather than just two per character.  The
TS2068 was released in late 1983, which of course begs the
question: why weren't either of these video modes built-in to the
Spectrum 128 in 1986?
The TS2068 was only compatible with about 10% of Spectrum
software (a Spectrum emulator cartridge had to be plugged in to
get 100% compatibility); a few have speculated that this might
have been one of the reasons for its downfall.  The TS2068 was

nothing like as successful as its British counterpart and was
withdrawn from sale in 1984.  Meanwhile Timex Portugal re-
leased a version of the computer - The TC2068 - for European
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use (compatible with European televisions and with a Spectrum-
style edge connector where the TS2068 had used a ZX81-style
connector)  and a 'cut down' version without the cartridge port
and AY chip called the TC2048. It's this latter version that
vbSpec emulates.  The TC2048 was actually almost 100%
compatible with Spectrum software.  Although it didn't have the
AY sound chip it did retain the video modes of the TS and
TC2068. Very little software was produced for it, however, which
is a great shame.
vbSpec's main claim to fame, of course, is that it's written
entirely in Microsoft Visual Basic. Programmers, I gather, are
impressed by that.  The emulator was developed originally by
Chris Cowley and is currently maintained by Miklos Muhi.
Also it's the only Spectrum emulator to emulate the ZX Printer
and include the form feed button.  You see, it's the little things
that please me...

Es.pectrum
Still on the subject of official Spectrum variants (as opposed to
the Russian and Eastern European clones, which were entirely
unofficial), it's worth mentioning also the Spanish machines.
Just as Sinclair joint-ventured in the US with Timex, so it teamed
up with Investronica in Spain.  It was actually Investronica who
developed the first Spectrum 128, which was released in Spain
in 1985 - the British version wasn't released until the following
year.
The Spanish 128 is pretty much identical, hardware-wise, to the
British version, however it didn't use the familiar menu system of
the British 128 - that was developed later.  Instead it features a
built-in text editor; it's not particularly complex and greatly inferior
to the various word processors of the day (which is probably why
Sinclair dropped it for the British version in favour of a more
user-friendly interface), but it's a curiosity, nonetheless.  Which
brings us nicely to Spanish Spectrum emulator Es.pectrum by
Javier Chocano. In addition to all the British machines and the
Russian Pentagon and Scorpion clones, Es.pectrum also emu-
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lates all the Spanish variants on the Spectrum also.  A French
version of the +2 is included too for good measure.  It's certainly
the biggest range of models I've seen an emulator cover.

Warajevo
No longer maintained and a DOS emulator for much older PCs
than the current standard, Warajevo is nonetheless a highly
significant Spectrum emulator.  Developed in Sarajevo during
the Bosnian War by Samir Ribic and Zeljko Juric, the emulator
was an attempt by these two "to remove the dark thoughts" from
their heads.  Amidst falling grenades, sniper fire, power-cuts and
very little food to eat, Warajevo was a lifeline to its developers
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because it reminded them "of all of the times when, in [their]
neighbour-hoods, the life was nice and normal".  It was one of
the first Spectrum emulators for the PC.
Warajevo is today a dated emulator, although it remains the only
dedicated Spectrum emulator that I am aware of to support the
Timex Sinclair 2068 (the American version of the Spectrum).

X128
X128 is a DOS Spectrum emulator written by James McKay that
supports a wide range of file types, including .TRD TR-DOS disk
images and .MGT Disciple disk images.  Like most DOS
emulators, it's not happy on Windows XP, but on earlier versions
of Windows it works just fine.  Speaking personally, this is the
emulator that seems to work for me on overstretched systems
when others fail.  I have a Toshiba laptop that runs Windows 98
on 16Mb RAM, for example, and X128 seems quite at home
there.

ZX32
ZX32 is a Windows Spectrum emulator by Vaggelis
Kapartzianis. This was one of the first Windows emulators and
remains a very popular, very widely used program.  It hasn't
actually been updated since 2000 and, as such, does not com-
pare well on features next to the likes of SPIN and
Spectaculator. As emulators go, however, it's a very straightfor-
ward and uncomplicated piece of software and I suspect this
accounts for a lot of its continuing appeal.

SpecEmu
Another Windows emulator, this time by SPIN co-author Woody.
SpecEmu supports just the British Spectrum models, loading all
the associated file formats.  
An emulator with a sense of humour, SpecEmu includes also an
option to simulate the infamous audio distortion of the Spectrum

 56 The ZX Spectrum on your PC



+3!  'Error emulation' is a topic that often comes up for discus-
sion in the various on-line discussion forums such as WoS
Forums or comp.sys.sinclair; it seems modern emulators are just
too perfect for some to allow them to truly connect with their
past.  Proposed new features have included tape loading error
emulation and interface wobble emulation.  So you see, there's
plenty left to do in the emulator scene!
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Appendix I
Key websites

The number of websites dedicated to the ZX Spectrum is... big.
Here, then, are a few of the coolest corners of the Spectrum's
cyber-community.

World of Spectrum
The cornerstone of the Spectrum community.  An immense
archive of games, emulators, utilities, magazines and more.  A
very active discussion forum.
www.worldofspectrum.org

SinclairFAQ
A remarkable knowledgebase covering many, many aspects of
the Spectrum and its community, from emulators to weblinks to
technical information.  So much more, in fact, than a mere FAQ.
www.sinclairfaq.com

raww.org
The best site for Spectrum news on the net, updated very
regularly and drawing from a wide range of sources - everything
from emulators to demo scene events.
http://raww.org



Demotopia
The Spectrum demo scene produces some of the most breath-
taking graphics, music and animations ever seen on the
Spectrum.  You won't believe your eyes.  Demotopia is your
gateway to it all.
www.zxdemo.org

The Tipshop
A vast on-line database of hints, tips, pokes and maps for over
two-and-a-half thousand Spectrum titles.
www.the-tipshop.co.uk

Planet Sinclair
All things Sinclair, from radios to the Spectrum to the TV80 flat-
screen TV  to the C5 electric car.
www.nvg.ntnu.no/sinclair/
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Magazines
World of Spectrum now hosts an immense collection of maga-
zine scans, including Crash, Your Sinclair, Sinclair User, Sinclair
Programs and MicroHobby magazine for Spanish users.  But
there's also the website versions of the 'big three' to browse:

Crash www.crashonline.org.uk
Your Sinclair www.ysrnry.co.uk
Sinclair User www.sincuser.f9.co.uk

Retrospec
Not exactly a Spectrum website; actually it's a website for
remakes of old games from a number of different 'vintage'
platforms.  As the name suggests, however, many of these were
either Spectrum games originally or Spectrum game inspired.
You won't believe what you can download for nothing here.
http://retrospec.sgn.net/

ZXF magazine
Shameless self-plug here.  ZXF, in case you didn't know, is my
PDF magazine covering all of the goings on in the Spectrum
world today.  It's published every April, August and December.
And it's free.  You can pick it up from the ZXF website, where
there are other on-line features to explore too.
www.cwoodcock.co.uk/zxf
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Appendix II
Key documents

The assumption I've made throughout this book is that you're
well able to operate a ZX Spectrum; you just need a little help
with the PC emulators.  Bearing in mind it might be nearly twenty
years perhaps since you last used a Spectrum, I suppose that
might not actually be a valid assumption at all.  It matters not, for
there is plenty of original Sinclair documentation to be found on
the web which will refresh your memory of all the various BASIC
and DOS commands.  
The information below should serve as a handy guide.  For much
more in-depth and up-to-date lists, consult these pages also:

www.sinclairfaq.com/cssfaq/resources/documents.htm
www.worldofspectrum.org/documentation.html
www.madhippy.com/8-bit/index.php?machine=sinclair

Spectrum manuals
48K Introduction booklet 
www.worldofspectrum.org/ZXSpectrumIntroduction/
48K Spectrum manual 
www.madhippy.com/8-bit/sinclair/zxspecman/
128K Introduction booklet
www.worldofspectrum.org/ZXSpectrum128Manual/
Spectrum +3 manual 
www.madhippy.com/8-bit/sinclair/zxspec3man/index.html



Disk interface manuals
ZX Interface 1 and Microdrive manual
www.madhippy.com/8-bit/sinclair/zxif1micro.html
Beta 128 Disk Interface manual (TR-DOS)
www.madhippy.com/8-bit/sinclair/betadisk/manual.txt
MGT Plus D manual   
ftp://ftp.worldofspectrum.org/pub/sinclair/technical-
docs/MGTPlusD_Manual.zip
Opus Discovery manual   
ftp://ftp.worldofspectrum.org/pub/sinclair/technical-
docs/OpusDiscovery_Manual.rtf

Other peripheral manuals
ZX Printer manual 
www.madhippy.com/8-bit/sinclair/zxprinter/index.html
Multiface 1 manual 
www.madhippy.com/8-bit/sinclair/multiface1.html
Multiface 128 manual 
www.madhippy.com/8-bit/sinclair/multiface128.html
Multiface 3 manual   
ftp://ftp.worldofspectrum.org/pub/sinclair/technical-
docs/Multiface3_Manual.txt
Currah µSpeech manual    
www.madhippy.com/8-bit/sinclair/microspeech.html
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Appendix III
comp.sys.sinclair

These days, the forums section of the World of Spectrum web-
site is probably the main on-line area for Spectrum related
discussion and debate.  But before WoS Forums the
comp.sys.sinclair newsgroup was the number one Spectrum
cyber hang-out.  It's still a very busy place today too, of course,
although be prepared that conversation is just as likely to focus
on the crisps, sweets, fizzy drinks and TV programmes of the
1980s as it is Sinclair computers!
CSS has been around since December 1993, and in this time it's
grown its very own culture and terminology.  Did you know, for
example, that:

chuntey is the mystical aura surrounding your Spectrum
whilst you load in a game?  Disruption of the chuntey by, for
example, the switching on of a local electrical appliance or by
your mother waking into the room is highly likely to result in
an 'R Tape loading error'.
cheatingbastness is the term applied to computers very
obviously and shamelessly cheating in order to bring about
your demise.  Never ever allow the computer to roll the dice
in Sinclair's Backgammon, for example.

The comp.sys.sinclair Folklore FAQ expands on these and many
other terms, and forms a part of the Sinclair FAQ at
www.sinclairfaq.com.
The largest part of the Sinclair FAQ, in fact, is the main



comp.sys.sinclair FAQ. Not so much an FAQ about CSS as it is
an FAQ about Sinclair stuff by CSS members, the main page
nevertheless does give you some important information which
you should read through before posting yourself.  CSS is a
strictly text only newsgroup, for example, so please don't attach
any files to your posts or post in HTML.
If you've never accessed a newsgroup before and don't under-
stand what this is all about, you should be pleasantly surprised
to learn that you can use plain old Outlook Express - the
Windows email program - to read newsgroup messages. You
can also get dedicated 'newsreader' programs, but if you're new
to all of this Outlook Express is probably the easiest place to
start. Newsgroups, incidentally, predate the web by many years
(for example, net.micro.zx was a newsgroup for the Spectrum -
actually for the Spectrum - set up in 1982), which is why they are
primarily text based.

Your ISP (internet Service Provider) should provide the news-
group access for you that allows Outlook Express to connect to
groups like comp.sys.sinclair - actually ISP newsgroup access
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does tend to vary from ISP to ISP, but most do provide access to
CSS (where it tends to vary is in access to the binary news-
groups such as alt.binaries.comp.sinclair).  In Outlook Express,
choose Tools > Newsgroups and type comp.sys.sinclair into the
box that appears.  Then it's simply a matter of selecting the
group and clicking on 'subscribe.'  The newsgroup should now
appear in the main Folders panel; click on it, and up come the
messages.
For any newsgroup, there are a few netiquette niceties you
should be aware of before making your first post.  First off all,
don't 'top-post'; when making a reply to someone else's post, put
your comments below the bit of their post you're replying to.
Don't quote enormous chunks of text from others' posts - just
include the bits relevant to your reply.  Don't 'cross-post' your
message (post to more than one newsgroup at the same time)
unless its absolutely relevant to all the groups included.  And
don't type your messages all in capital letters.
Just in case your ISP doesn't provide newsgroup access (also
sometimes referred to as Usenet access), you can still get to
CSS via Google's Google Groups archive on the web.  Simply
visit www.google.com and type 'comp.sys.sinclair' into the
search box, then click on 'Groups' and hit the 'Google Search'
button.  The Google Groups archive goes back years and years
and years (you can even search net.micro.zx if you want to) and
you can search it in exactly the same way that you search the
web with Google, so this is an immensely rich and valuable
information source.  If you've got a question to ask it's always
worth checking Google Groups first - the chances are fairly good
it's already been asked and answered (possibly several times
over).
The CSS community do do other things besides talking about
Rolos.  There's the annual comp.sys.sinclair Crap Games
Competition, for example, which is always hosted (on a web site)
by a CSS member.  A celebration of the appalling quality of the
contents of the Cascade Cassette 50 games compilation, CSS-
CGC has been running since 1996 and resulted in some quite
dreadful games.  The titles quite often speak for themselves:
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The Amazing Tony Blair Experiment
Fuel Protest 2000
Lying Minesweeper
Advanced Weapons Inspector Simulator
Chuckle Brothers Golf

The Crap Games Competition is now such an established event
it even has its own web ring!  You can check it out at
http://r.webring.com/hub?ring=crapgameswebring.
And then there's the annual Speccy Games Tournament, for
which a number of classic games are chosen by the group and
played by entrants to see who can score the highest.  Competi-
tors record and submit an RZX file (see chapter 4), so there's no
possibility of cheating!

 66 The ZX Spectrum on your PC



Index

+3e interface, 50

AIR input file format, 28, 30
Alphacom 32 printer, 24
alt.binaries.comp.sinclair, 65
Amstrad, 3, 25
Audio recording, 30
AVI video file recording, 30
AY audio chip, 3, 35, 38, 52
AY Riders, 38
AY-3-8910/12 Emulator, 38

BASIC loader, 4, 5, 8
BASin development utility, 35, 36-37
Beta Disk Interface, 2, 23, 45, 50, 

62
BMP graphics file format, 31
BMP2SCR graphics utility, 34

Cascade Cassette 50, 32, 65
Cassette image files, 4-8
Centronics port, 20, 24
Cheatingbastness, 63
Chuntey, 63
Clones, Russian, 44-48, 54
Code Masters, 16
comp.sys.sinclair, 32, 63-66
Crap Games Competition, 32, 35, 

65-66
Crash magazine, 60
Cronosoft, 17
Currah µSpeech interface, 25, 62
Cursor joystick standard, 19-20

Demotopia website, 44, 59
Disciple disk interface, 26, 50, 56
Disk images, 9-12
Distribution permission, 16
DSK +3 disk file format, 9, 11
EAR socket, 22
EmuZWin emulator, 51-52
Es.pectrum emulator, 54-55

Gamebase ZX database, 39, 40
Google groups, 65
Gosh Wonderful alternative ROM, 

14

Hi-Soft BASIC compiler, 34

IMG disk file format, 26
Input recording, 27-30
Interface 1, 9, 10, 62
Interface 2, 19
Investronica, 54

Joysticks, 19-20

Kempston joystick standard, 19-20
Kempston mouse, 25
Keyboard, 12-14

Lens Key, 52
Lenslok, 52
Lightgun, 25
Line-in socket, 1, 22
Loading from audio source, 22-23



Loading screen, 5
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Plus D interface, 26
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Spectrum Games Database (SGD), 
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SPIN emulator
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UDGs (User Defined Graphics), 35, 36
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ZX32 emulator, 56
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ZXCF interface, 50
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ZZ Spectrum emulator, 39
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BACK TO THE SPECTRUM!
More than twenty years on from its original
release, the best-selling Sinclair ZX Spectrum is
now one of the most emulated computers in the
world.  Far from dead, a thriving community of
enthusiasts has kept the spirit of this little machine
alive through an enormous range of emulators for
just about every modern computer platform there
is.  For the PC in particular, the complexity of these
emulators is simply amazing.
With the rise in interest in retro-gaming, the
Spectrum community is starting to grow again as
more and more one-time Spectrum owners come
back to their computing roots to rediscover the 8
colours and 48K that somehow captured their
imagination back in the 1980s.  If you are one of
these people then this book is for you.  
Focusing primarily on the two most popular
Windows emulators, Spectaculator and SPIN, The
ZX Spectrum on your PC explains all the main
features of these programs.  Illustrated
walkthroughs teach you everything from how
individual cassettes are emulated to how to print
from your virtual Spectrum.  In no time at all you'll
find yourself enjoying all the old games and
activities of your youth... on your PC!

The Author
C. Woodcock is the editor of ZXF magazine.  He has also
written several articles on the ZX Spectrum for Micro Mart
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